MAINNET:
Loading...
TESTNET:
Loading...
/
onflow.org
Flow Playground

Installation

This chapter explains the installation of the FCL JS library in your system. However, before moving to the installation, let us verify the prerequisite first.

Prerequisite

  • Node.js version v12.0.0 or higher.

FCL JS depends on Node.js version v12.0.0 or higher. You can check your currently installed version using the below command:

node --version

If Node.js is not installed on your system, you can download and install it by visiting Node.js Download.

Install FCL JS using npm or yarn

npm i -S @onflow/fcl
yarn add @onflow/fcl

Importing

ES6

import * as fcl from "@onflow/fcl";

Node.js

const fcl = require("@onflow/fcl");